So, I installed tuist as per instructions, it installed 1.11.1. While I did this, I had Xcode 10.1 activated through Xcode-select (although I don’t think that matters). Basic tuist commands seem to work.
Next I attempt to run “tuist generate” for a project that I have. This project has, in its configuration (Config.swift):
compatibleXcodeVersions: ["10.1"] and got:
/Users//Documents/Dev/Dolf/SFLibraries/Tuist/ProjectDescriptionHelpers/Project+Templates.swift:1:8: error: module compiled with Swift 5.1.3 cannot be imported by the Swift 4.2.1 compiler: /Users/dolf/.tuist/Versions/1.11.1/ProjectDescription.swiftmodule
The ‘swiftc’ command exited with error code 1
This seems to be caused by a pre-compiled version of ProjectDescription.swift located in
I then tried to install things while 10.1 was selected by running:
tuist uninstall 1.11.1 followed by
tuist install --force 1.11.1:
The '/Applications/Xcode 10.1.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/swift' command exited with error code 1 and message: /private/var/folders/ls/vpdknw1n5h3fvr3vpxm44zrr0000gn/T/TemporaryDirectory.Tr3VwL: error: package at '/private/var/folders/ls/vpdknw1n5h3fvr3vpxm44zrr0000gn/T/TemporaryDirectory.Tr3VwL' requires a minimum Swift tools version of 5.1.0 (currently 4.2.0)
So, at this point I am at a loss on how to do this. The idea one can configure minimum Xcode versions in the Config object, yet if that version is a bit of a distance in the past, it cannot actually work is confusing to me.
Please let me know what I am missing or doing wrong, or that it is understood that when the Xcode compiler is different, perhaps there should not be a pre-compiled version of the configuration based objects, but rather they should be compiled as part of the generate step…